Page 1 of 1

Can't run Desert Combat

Posted: March 11th, 2019, 5:23 pm
by Trench
majpj on Mon Mar 11, 2019 2:01 pm wrote: Trench, please help me. i was told you were the one to contact to help me resolve an issue trying to get battlefield up and running. i hope i hope i hope , you can help me. its complicated. battlefield 1942 {the bare minimum } is up and running on my computer. i want to freshly install and have all the maps and whistles . windows 10 , i even made a partition , continue error of installation support file could not be removed . access denied. its a file in temp ending in ..........._lsRes.dll

Buddy from ea117 i used to play with was wondering why i never came back, its because i just cant. only one server in menu that works now, and thats --==[aX]==--.
So the issue is in trying to install Windows 10 on a new partition?

Or the issue is when trying to re-install everything fresh, and fails when trying to re-install Battlefield 1942 itself?

Or the issue is when trying to add Desert Combat to your existing (and working) Battlefield 1942 installation?

Still trying to get a sense of exactly what is being attempted, and where exactly this error shows up. If you had screen shots you could post, that might help too.


Re: Can't run Desert Combat

Posted: March 12th, 2019, 8:29 pm
by majpj

Re: Can't run Desert Combat

Posted: March 12th, 2019, 9:15 pm
by Trench
I'm presuming that's the Battlefield 1942 installer (and not the Desert Combat or DC Final installers).

"Access denied" in the AppData folder is a bit unusual, since you're supposed to have full rights there even without "running as administrator" or any kind of rights elevation. I would suspect maybe my anti-virus program is getting in the way (not that I'm a fan of turning off anti-virus, even for troubleshooting), or that something has literally abandoned a file secured with permissions that aren't default.

In terms of "easier things to try", what comes to mind is enabling your Administrator user, and login as the actual Administrator user just long enough to attempt installing Battlefield 1942 that way. If the same issue occurs then (which is an entirely different AppData directory), then I would have to suspect something like my anti-virus getting in the way, since it's happening even on a "brand new" Windows user and AppData directory. It that case you might have to entertain turning off any anti-malware or other "protection" software that could be intentionally intercepting your install attempts, and doesn't like something about this old 2003 installer.

You might have already seen them, but these steps are the ones we expect and use for getting Battlefield 1942 and Desert Combat and PunkBuster running, even on Windows 10: HOW TO: Use the CD-based Battlefield 1942 game to play on the EA117 server

Note on this site ( all you need to do for taking a screen shot is press ALT-PrtScn (to capture just the current application window) or PrtScn on its own (to capture the entire screen) and then when posting or making a reply in the full editor, simply press CTRL-V or CTRL-Insert to paste the captured image as an attachment. (No need to "save it as a file first in order to attach it".) Note this doesn't work in the "Quick Reply" editor, only the full reply editor, because you can't make attachments at all in a quick reply.

Re: Can't run Desert Combat

Posted: March 13th, 2019, 7:17 am
by majpj
Ok thanks trench, wilco on McAfee. That I one thing I haven't tried yet. Understood about screen shot.

Re: Can't run Desert Combat

Posted: March 15th, 2019, 2:02 pm
by mistamontiel

n have 7-Zip @ the ready, extract to the Mods directory

Re: Can't run Desert Combat

Posted: March 15th, 2019, 7:03 pm
by Trench
Thanks mistamontiel. If the issue actually is in one of the Desert Combat mod installers, indeed this might provide a second way to solve the puzzle. I couldn't quite tell in the screen shot, but I got the impression it was the Battlefield 1942 installer throwing the error we saw. Which isn't normal, even for Windows 10.

Re: Can't run Desert Combat

Posted: March 31st, 2019, 10:26 pm
by jolly_mario_batali
majpj: good to see you this evening.

If you continue to have issues and Trench's fixes don't work, there is an alternative strategy for one-stop-shop installing BF1942 + DC:


Note that this comment does *not* indicate that the admins endorse this method. However, it does work.